Cisco ASDM error with latest java update

Well it seems the current update to java (6 update 10) does not work with Cisco ASDM. After the update trying to connect to a Cisco ASA will give the following error: “Unconnected sockets not implemented”. CLI still works of course but if you use ASDM don’t upgrade past JRE 6 update 7. You can get older java versions here.

My config: Vista Ult x64 – JRE 6 u10 – Cisco ASDM 6.1(5) (most current ASDM as of now)

What I had to do to access ASDM after the java 6 update 10 “upgrade”.

1) Remove ASDM* (ASDM installer seems to look for java so this must be done before removing java)

2) Remove Java 6 update 10

(I rebooted here)

3) Install Java 6 update 7* (I ended up running both the 32bit and x64 installs. I think because ASDM is 32bit and didn’t see the 64bit Java install?)

4) Re-Install ASDM

*Note: It may not be required that your remove ASDM on a 32bit system or if you install the 32bit java 6 update 7 as ASDM may just see the new (older) java install. When I installed the 64bit java this is what I had to do.

Best of Luck and I hope this helps someone out.

Tagged , , , . Bookmark the permalink.

2 Responses to Cisco ASDM error with latest java update

  1. cpetty says:

    See Cisco bug ID CSCsv12681. — Error while loading ASDM: “Unconnected sockets not implemented”

    http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCsv12681&from=summary

    Looks like this is fixed in the following ASDM versions.
    6.2(0.70)
    6.2(0.71)
    6.1(1.55)F
    5.2(4.51)
    6.1(5.51)

  2. Heavens says:

    Thanks for the post. I’m glad they have the bug flagged as fixed but the versions of ASDM that fix the problem are not released as of now. ASDM 6.1(5) is unfortunately the current stable release. Is that not the case?

Leave a Reply